Old Add-ons not working on Firefox 4? Workaround to Install them

Mozilla Firefox 4 final build is available to download. It comes with so many new features and performance enhancements. The visible change in UI is much better than the previous versions but it has one problem. Like other major releases of Firefox, old add-ons are not working or not compatible of Firefox 4. They do not pass the compatibility test as they were made for Firefox 3.x versions. Here is a workaround to make them working and running on Firefox 4.

[ad id='9' style='float:left;margin:10px 5px 10px 0px']

firefox-4Are you comfortable with installing one more add-on which will make others work properly on Firefox 4? If yes, then go ahead and install Compatibility Reporter add-on which is available in official add-on directory.

Once you will install this add-on on Firefox 4, your old add-ons will start working properly. Isn’t it as simple as just installing a new add-on on Firefox.

Interesting part of using Compatibility Reporter is that you can use this trick for future releases as well. That means, when Firefox 5 will come, again your old add-ons will stop working. You just need to update the Compatibility Reporter to latest version to make old add-ons working.

I tested this trick on YSlow which had stopped working on Firefox 4. Now its running smoothly without making any changes.

Another trick to avoid compatibility test

If you are not comfortable with installing another add-on on Firefox or in case Compatibility Reporter has not been updated to the latest version, you can use another trick by adding a new preference in the configuration file of Firefox.

Type about:config in the address bar of Firefox 4. Right click anywhere on the new window and select New ==> Boolean from there. A new box will appear where you need to type “extensions.checkCompatibility.4.0” without quotes. Set the value to “false”. Done, now you can see your old add-ons working on new Firefox 4.

firefox-config

You can use this trick in future releases as well. For example, once Firefox 5 will come, you just need to type “extensions.checkCompatibility.5.0” and set value to “false”.

Using above tricks, you can make all old add-ons working on new releases of Mozilla Firefox.

Sanjeev Mishra is a professional blogger and an Internet Marketing Consultant based in India. He has built the Internet Techies to provide you updates in technology and web application area.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>