Post WordPress Plugin Compatibility On WordPress Plugin Directory

WordPress has just released WordPress 2.8.5 upgrade and also the testing version WordPress 2.9 is available for wp-testers. WordPress 2.9 beta is probably expected to be released at the end of October 2009. So, everyone of us uses atleast 5 wordpress plugins and atmost hmmm…I cannot guess, that is a poll question! But, how would people downloading a plugin from WordPress Plugin directory know that whether that plugin is compatible and fully functional on their WordPress installation or version, this was an obvious question.

Now a user of plugin on WordPress Plugin Directory can post his/her experience with that particular plugin compatibility with his/her wordpress installation thru a ‘Compatibility’ poll. Have a look at the below box added for every plugin on the WordPress plugin directory in the right sidebar.

plugin_compatability

1. ‘Broken’ means that when you install and activate the plugin, it is causing some fatal error, or it is not working with its basic functionality. Please do not press this button, if you feel that the plugin is having some general issues or small impacts on other functionalities. It does not mean that the plugin is broken for the WordPress installation, post those issues in the plugin forum. Broken actually means that ‘certain’ feature was working in some other version, but now when upgraded to new version of WordPress that feature stopped working, i.e. the feature or the plugin is broken.

plugin_compatability2

2. If you find that the plugin you are currently using are working perfectly on WordPress 2.8.5, or your WordPress installation version, do post your vote as doing that you would help the new probable bloggers who have a need to use that plugin make a better decision and will not find themselves helpless when they activate some incompatible plugin and now their admin screen is showing ‘White Screen of hell’, a fatal PHP error. As every blogger is not a PHP programmer, this could a big headache for them, and in some cases to you too. So, this is a very good feature WordPress is trying to include on the Plugin Directory, let us all support it.

This feature on the plugin directory is in Beta version, still I feel it is excellent and working fine.

Use it and post your votes. Please share your experiences with this plugin compatibility feature recently added by WordPress in the comments section of this post.

Also read => Smooth Slider, one of the simplest and best image and content slider is compatible with WordPress 2.8.5 and 2.9

  • You Know What Happened?
    This Morning, I was unable to Visit my site itself, and when i went through FTP my default folder of chaaps.com was renamed into chaaps.com_possible_exploit_content_contact_dreamhost_support!! i was just shocked! and when i contacted the dreamhost support they said me… i need to upgrade wordpress to 2.8.4 to new one.. as the hackers can exploit outdated software!!!
    i never knew .. upgrading to latest wordpress is so critical!!
    OMG! i lost traffic for more than 2 hours!!
    finally i upgraded to 2.8.5 and renamed folder back to chaaps.com!!!
    Now everything Ok! nice experience na ? has anyone faced similar such problem like me?