WordPress 3.0.2 Is A Mandatory Security Upgrade

Yesterday, WordPress 3.0.2 was released and according to WordPress guys, it is a mandatory security upgrade. All the WordPress sites should immediately upgrade the previous versions to WordPress 3.0.2.

WordPress_3.0.2

In the previous versions, there was an issue that gave some special permissions to WordPress site’s malicious Author-level user, so that he can gain more access to the site thus making your site prone to attack. If you have all trusted users or say not a lot of users, though you should upgrade your WordPress version as it is highly recommended.

The WordPress 3.0.2 release also fixes some minor bugs like

1. Fix occasional irrelevant error messages on plugin activation.

2. Remove pingback/trackback blogroll whitelisting feature as it can easily be abused.

3. Fix canonical redirection for permalinks containing %category% with nested categories and paging.

And it also has some bug fixes for multisite installation.

You can find more details about the changelog of this release here.

And you can read the official WordPress release note by Mark Jaquith here.

So, make your WordPress site safe by upgrading, as it should be priority. Happy blogging.